Skip to main content

V1 stuck on logo screen



  • asc

    Turns out, after I left it connected to wall charger for a few hours, and then turned it off and on, it starts working. It would appear it has something to do with the internal battery.


  • Permanently deleted user

    Thank you for contacting Rexing.

    We would like you to perform a firmware update just to be on the safer side.

    Please visit and watch this video that teaches you how to do a firmware update

  • asc
    thanks for your support. When I follow the link and use the tool, the tool says i'm on the latest.
    I have V1, and I believe it's the basic (HD, single camera).
    so i select: V1 or V1G
    FW on it is B50.2016.1017.V1.2
    and the tool says i have the latest.
    Should I use a different product link? if not, which FW instead should I try to load?
    btw, I thought this thread is just for users to reply to, so i started a support thread here: 
    now these two are duplicates. Sorry about that.
  • Scott Vanderstelt

    I did a firmware update from B50.2017.0116.v2.4 to the latest firmware and now my V1 is stuck on the logo screen. I followed the video and even paused it while I was doing the steps.  How is it a firmware update just bricked my camera and made it useless?

  • asc

    I found out that if I plug it in for a few hours (I use wall charger for this), it will start working, but will eventually stop again, so seems like something to do with the battery, even though it's not running on the battery.

  • Permanently deleted user

    Thank you for contacting Rexing.

    Please reach out to customer support at

    We want to do some more in-depth troubleshooting 

  • Yan Gilchenok

    I have the same problem as Scott described above.

    I am attempting to update the firmware for Rexing V1 2nd Generation Early Model Firmware

    Prior version loaded was: b50.2017.0116.v2.4

    Found this in Firmware Downloads: Stable version: V1_Gen2Early_180125
    Release date: 2/24/2018
    Version: B50.650.323.180125HY.03

    Followed instructions to load the files to SD card. Update process freezes. Tried to reset and re-start the update. 5 seconds power on, 5 off, 5 on and wait. Still not updating and dashcam is stuck loading.

    Device is V1 FULL HD 1080P.

    Emailed support but not getting resolution.


Please sign in to leave a comment.

Powered by Zendesk