Skip to main content



  • Amit Vohra

    Thank you for contacting Rexing.

    Kindly put your dash cam back to default settings and use this GPS player to see if that helps.

    If its still not helping please email us @

  • Chris Neilson

    I have the same problem with my V5. I’ve tried resetting the camera and then ultimately replacing it. The replacement has the same problem. I noticed the GPS coordinates are correct at the start up location but do not refresh. This could explain why I don’t see a speed but now need to resolve the GPS not refreshing. I haven’t reviewed this unit yet and have two installed in two different vehicles. I would like Rexing to respond with a solution. I believe the unit should work as advertised .

  • Johan

    Chris Neilson ... I'm having the same issue that you are. Were you able to get a solution to the issue?

  • Stan Roper

    Do we have an actual fix for this? My family is pretty disappointed with the non-response here and has already had several occasions where knowing the MPH/KMH would have been really helpful.

    Rexing, what's the plan?? Other than resetting, as Chris indicated that does little to help. Even replacing the camera didn't fix this...

  • Samuelfergusoniii

    I'm having that same problem with the V1P 4k , it only reads 0 while I'm driving, could the GPS logger be defective? I've reset it several times and  updated the firmware . What else can i do ?

  • Leefield A

    Hi, the GPS logger could be the problem and we would like our support team to take a look at the issue you are having.

    Please contact support at


Please sign in to leave a comment.

Powered by Zendesk